This project has moved and is read-only. For the latest updates, please go here.

Alpha 3 -- initial issues

Mar 13, 2015 at 10:39 PM
Congrats on the new release! Thank you for your work. I've really enjoyed this product over the past few months and I look forward to continued development. Here are initial observations about the α3 installation.

I'm running Win 8.1 on a HP Envy notebook.

In order to "start from scratch," I removed (renamed, actually) the BrowserChooser2Config.xml file so α3 would begin fresh. I did not import from BC1, but it still said, "Failed to load settings. Default settings used." This implies an error where none really exists. I think if the import is not done, the program should simply continue without any message.

Next, it showed the browsers it found and also displayed the "Download update?" dialog box. I'd think this dialog should not appear here, since I am running the latest version. I closed that dialog box and continued.

α3 found 3 browsers: IE, Firefox, and Chrome (displayed in that order). It did not find Opera nor Safari. If I click any browser icon, the browser attempts to load as expected, BUT BrowserChooser2Config.xml is not created. Unless I specifically select Options | Save, the xml config file is never created. I think a default config file needs to be saved at the first opportunity.

IE crashes every time. A message box displays:

"Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately."

"A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)."

There are details (accessed from a button) which I can provide, but will omit here due to length. Clicking continue leaves me at the α3 interface.

In order to test further, I restored the BrowserChooser2Config.xml file I have been using for the last several months with α2. When I launched α3 using this config file, I immediately went into settings to make sure things were "correct" for the new program (α3). For example, I moved command line arguments to the new "Arguments" box, whereas they had been in the "Path box" when I was running α2. I reviewed each of my browsers to verify settings. Other than moving the command line settings (as needed), everything else seemed to be fine. I saved the configuration and exited.

I have a 5 wide by 3 high grid. The first row has Chrome, Firefox, IE, Opera, and Safari. The second row has "private/incognito" versions of each of these (except for Safari, for which I cannot find a way to launch in private mode.) I typically use the top row for launching browsers. I use the private/incognito versions -- usually just chrome -- when I click links from email newsletters that I want to read, but don't want cluttering up my browser history. (One newsletter that I read on a daily basis often has 50+ links and I read most of the articles. Way too much history for articles that I won't read again, and thus don't want littering my history.) On the third row, I have one icon to launch the very latest version of Firefox with a plain user profile. My "normal" and "incognito" versions on row 1 and 2 use a slightly older version of FF with a highly customized profile.

While in the α3 interface, I've observed that the hotkeys -- assinged and numeric -- work as expected. Clicking any icon works fine. However, using the arrow keys produces some surprises. Pressing Right/Left arrows (or Tab and Shift-Tab) moves through all icons on the screen, including the info, settings, and clipboard icon. Up/down arrows act exactly the same. So, moving between rows cannot be done with a single press of Up/Down. I think it would be preferable to have Left/Right arrows move ONLY left/right on a SINGLE row, to have Up/Down arrows to move ONLY between rows, and to have Tab move among the three "blocks" of icons. That is, while on a browser icon, tab would move to the settings/clipboard area. Tab from there moves to "info." Tab again moves to browser icons. Shift-Tab would go in reverse order. Just my opinion, of course. Maybe others like the arrow and tab key operation as it is. Interestingly, pressing Enter while on any Browser Icon does nothing. Pressing the hotkey or clicking with a mouse is the only way to launch. Pressing Enter on info, settings, or clipboard icons invokes the expected action.

Here's what I've found in launching the various browsers/configurations from A3:

All of the row 1 ("normal" configurations) work just fine, except for IE, which crashes every time as noted above.

Row 2 -- the private/incognito options of Chrome, Firefox, IE, and Opera -- has some issues: When launched without a URL (i.e. launch α3 and click the incognito Firefox link in row 2), Firebox works perfectly, starting in Private Browsing mode. When lauching a URL however (click a link in an email, for example, and selecting the FF incognito link from row 2), Firefox launches two windows. An "empty" Private Browsing window appears and the requested URL launches in a separate, non-private window. Odd! IE crashes every time, with or without a URL. Opera launches in private mode without a URL, but when a URL is passed, the link open in non-private mode. Interestingly, in α2, when I had the command line arguments with the path, private/incognito modes worked fine. (And for IE, too.)

Interestingly, the Firefox on Row 3 -- different version of FF with command line override of profile -- works fine with and without a URL. This makes it all the more puzzling why the incognito version row 2 does not work correctly. I'll continue poking around a bit on this.

I hope this information is helpful.

Mar 13, 2015 at 11:27 PM
Wow. thanks for the feedback - hope I don't miss anything.

I always struggled on the best way to handle new users. I guess I could just kill the message now that it detects (some) browsers.

There is a significant bug with the update - I forgot to change the update code.

Right now, it only detects Firefox and Chrome. I will be adding Opera, Safari and Vivaldi (sp?) along with their developer editions. Probably next week.

You are right that it should save the new file without going into options.

I haven't had IE issues at work (IE8 / win7) so I will have to do some more testing. I tried to use the signing features of .NET but I think it just gives me more headaches than it's worth. I will definitely follow up soon on this.

Interesting simplification of the keyboard. That won't make it into my quick fix but definitely will in the next version - i am not sure how much work is involved.

Can you provide with the configuration file so that I can try your row 2 issues?

And if you don't mind, a screen shot too - I want to provide more examples on the main page!

thanks - all great information.
Mar 13, 2015 at 11:44 PM
Edited Mar 13, 2015 at 11:45 PM
Config file:
XML file


By the way, I was going to go back to using alpha2, but it brings up the "Upgrade" screen every time now, even though I have "check for updates" turned off. So, I guess I have to stay with alpha 3.

Mar 13, 2015 at 11:54 PM
Please try again, I just re-released Alpha 3 (as 3b) that fixes the update bug and the IE bug.

Thanks for the files - something for me to do this weekend!
Mar 14, 2015 at 12:49 AM
I downloaded α3 and continued using the config file I had (rather than starting from scratch).
IE now works in both of my configs ("normal" and "in private"), with and without a URL passed.
Opera DOES seem to be working correctly, too, so maybe I misspoke in my original message.
The latest Firefox works correctly, too, in both normal and private browsing.
The older Firefox still launches 2 windows when passing -private-window and a URL. This doesn't seem to be related to Browser Chooser, however, as it does the same thing from a command line. Odd.

One other thing I've noticed. Some of the browsers become the current/active application (i.e. running "on top") when launched from Browser Chooser and some do not. Is this something you can force to happen? It seems to me that if launching a browser, it should become the current/active application.
Mar 15, 2015 at 3:05 PM
Thanks for the update - looks like a FF issue.

I think it may be possible to force an browser / app to be on top. Will need to look into it.
Mar 16, 2015 at 12:12 AM
It does seems to be something with Firefox -- either that specific version, or perhaps my specific profile. The current version works fine.

One other issue I noticed: Adding Auto-URLs works fine, but when I click Edit, it does not bring up the highlighted entry.